RouterPassView

RouterPassView v1.15
Copyright (c) 2010 Nir Sofer
Web site: http://www.nirsoft.net

Description

Most modern routers allow you to backup the configuration of the router into a file, and then restore the configuration from the file when it's needed.

The backup file of the router usually contains important data like your ISP user name/password, the login password of the router, and wireless network keys.
If you lost one of these password/keys, but you still have a backup file of your router configuration, RouterPassView might help you to recover your lost password from your router file.

System Requirements

  • This utility works on any version of Windows, starting from Windows 2000 and up to Windows 7.
  • RouterPassView supports limited number of router models. See below.

Versions History

  • Version 1.15:
    • Added command-line support.
    • Fixed issue: Removed the wrong encoding from the xml string, which caused problems to some xml viewers.
  • Version 1.10:
    • Added 'Grab Password From IE Window' option - Allows you to open the router configuration interface in Internet Explorer, and then grab the password stored inside the password text-box of the router Web page.
  • Version 1.05:
    • Added support for D-Link DIR-300, and possibly similar models.
  • Version 1.04:
    • Added support for Sitecom WL-351, and possibly other models.
  • Version 1.03:
    • Fixed bug: user names of D-Link routers were wrong.
  • Version 1.02:
    • Added support for D-Link DIR-655, and possibly other models (with gateway_settings.gws filename)
    • Added support for Sanex SA 5100, and possibly other models.
    • Fixed bug: Copy to clipboard (Ctrl+C) was disabled in text mode.
  • Version 1.01:
    • Added support for Tomato firmware.
    • Added the password of 'support' user for D-Link DSL-2540U and possibly other routers.
  • Version 1.00 - First release.

Supported Routers

Due to large amount of router models available in the market, it's impossible to support all of them.
For now, RouterPassView supports a limited number of router models, and I'll gradually add support for more routers in future versions. Also, be aware that even if your router is not in the list, you can still try to open your router backup file with RouterPassView, because some routers are sold with different brand name, but they still use the same software/chipset of other routers.

Here's the list:

  • Linksys WRT54GL (With original firmware or Tomato firmware), WRT54G (only some of them), WRT160N, and possibly similar models.
  • Edimax BR6204WG, and possibly similar models.
  • Siemens ADSL SL2-141, and possibly similar models.
  • Dynalink RTA1025W, and possibly similar models.
  • NETGEAR WGT624, and possibly similar models.
  • ASUS WL-520g, WL-600g, and possibly similar models.
  • D-Link DIR-655, DIR-300, and possibly similar models.
  • Sanex SA 5100, and possibly similar models.
  • Sitecom WL-351, and possibly similar models.
  • COMTREND 536+ (Only Internet Login)
  • US Robotics 9108 ADSL (internet login and admin login)
  • D-Link DSL-2540U/BRU/D ADSL2+, DSL-2650U, DSL-520B
  • D-Link DVA-G3170i/PT
  • TP-Link TD-8810 ADSL Modem/Router.
If you have router model that is not listed here, and you managed to recover your password with RouterPassView, please report about it to nirsofer@yahoo.com and specify the exact model name.

Using RouterPassView

RouterPassView doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - RouterPassView.exe
After running RouterPassView, you can open your router configuration file by using 'Open Router Config File' option (Ctrl+O) or by dragging the config file from Explorer into the main window of RouterPassView.
If RouterPassView manage to detect and decrypt your router file, you should get a list of passwords/wireless keys in the main window of RouterPassView. If RouterPassView cannot detect your file, it'll remain empty.

Text Mode (Ascii and Hex Dump)

If RouterPassView shows you a list of passwords, but you can't find the password or other data that you need, you may try to locate your password by switching to Ascii Text Mode (F3) or Hex Dump Text Mode (F4).
In these modes, RouterPassView decrypts the router file, but display it "as is" without analyzing the data stored in it.

How to submit a config file

If you have a router config file that RouterPassView cannot decrypt and analyze, you are welcomed to send the sample config file to nirsofer@yahoo.com, and I'll try to figure out how to read it and add support for this file in future version.

You can also increase the chance of my ability to add support for your config file if you follow the submission instructions below. However, be aware that it requires you to disconnect your network and internet connection for a few minues.

  1. Backup your current router configuration and keep it in a safe place on your local disk.
  2. Update your router configuration with dummy user names, passwords, and wireless keys. You should use very simple passwords/keys, like 1111111111, 2222222222, ABABABABAB, 12345678, and so on. Putting these easy passwords give me a much better chance to crack the config file and find out how the passwords are encrypted.
  3. Save the modified dummy configuration into a file. This file should be sent to nirsofer@yahoo.com for examination.
  4. Restore your real router configuration from the file that you saved in the first stage.
  5. Send the backup file with the dummy passwords to nirsofer@yahoo.com, and specify the router model/firmware and the dummy passwords that you set in this config file.

Using the 'Grab Password From IE Window' option

If you try to recover your ISP/ADSL/L2TP/PPTP/PPPOE/DDNS password, but RouterPassView cannot decrypt the configuration file of your router, you still have a chance to retrieve the password by using this feature, assuming that you have the login password of your router.

In order to use this feature, follow the instructions below.

  1. Login into your router Web interface with Internet Explorer, and go to the password page that you wish to recover. This password page may look like this one:

    As you can see in the above screenshot, the password field is filled with bullets, but if this password field really contains the password, RouterPassView will be able to extract it and display it on the main window.

  2. Go to the File menu, and choose 'Grab Password From IE Window' or simply press Ctrl+G
  3. If the router Web page store the password in the password field, RouterPassView will display the hidden password:

    Be aware that some routers deliberately store wrong password in this field, and in for these routers, RouterPassView won't be able to recover your real password.

Command-Line Options

/RouterFile <Filename> | Specifies the router file to load.
/stext <Filename> | Save the list of router passwords into a regular text file.
/stab <Filename> | Save the list of router passwords into a tab-delimited text file.
/scomma <Filename> | Save the list of router passwords into a comma-delimited text file (csv).
/stabular <Filename> | Save the list of router passwords into a tabular text file.
/shtml <Filename> | Save the list of router passwords into HTML file (Horizontal).
/sverhtml <Filename> | Save the list of router passwords into HTML file (Vertical).
/sxml <Filename> | Save the list of router passwords into XML file.

Translating RouterPassView to other languages

In order to translate RouterPassView to other language, follow the instructions below:
  1. Run RouterPassView with /savelangfile parameter:
    RouterPassView.exe /savelangfile
    A file named RouterPassView_lng.ini will be created in the folder of RouterPassView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run RouterPassView, and all translated strings will be loaded from the language file.
    If you want to run RouterPassView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely use it at your home or in your company. However, you are not allowed to make profit from this software or to charge your customers for recovering their passwords with this software, unless you got a permission from the software author.
You are also allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com